Results 1 to 7 of 7

Thread: Poor MPG and Engine Running Rich

  1. #1
    DX User
    Join Date
    Mar 2018
    Posts
    12

    Poor MPG and Engine Running Rich

    Alright guys got something going on here. My mileage has dropped significantly. The car is barely squeaking 250miles to a tank avg 21-23mpg. This car was avg over 30mpg and on long road trips close to 50mpg. So something is telling the computer wrong info. Car doesn't seem to have a loss of power. Here's what's been done so far:

    Compression all 4 around 180psi
    No signs of head gasket leak in the oil or coolant.
    Changed some worn hoses and thermostat 180*(thought possibly stuck open)
    ECT changed incase was failing but ohm's were correct
    Plugs and wires good have about 25k on them
    Checked timing and vacuum advance
    No disconnected lines or sensors
    Sprayed for intake gasket or vacuum leaks none found
    No lights or codes
    O2 sensors were replaced. Have one Bosch and one denso(got a bad denso from the box) Thought this was original problem since I had 2 code hence the Bosch replacement. Code gone but still bad mpg.

    So my next step is to read the O2 voltage and see if them are playing nice.

    What are you thoughts. I have an intermittent hot start issue but I'm tying that to main relay which I haven't replaced yet.(I'd like to meet that smart engineer for location logic!)

    Thanks
    Guys



  2. #2
    LX User AWH's Avatar
    Join Date
    Feb 2017
    Vehicle
    Honda Prelude BA2 1987 2.0-16V. B20A1
    Location
    the Netherlands
    Posts
    140

    Re: Poor MPG and Engine Running Rich

    I do know that the Bosch O2 sensors are the worst. Denso is the brand to have.Not sure if that will solve your problem. Your cat could be clogged,telling your ecu wrong info I guess. Replace cap & rotor, small investment, rule that out.Did you check your plugs and wires Or assumed good because of mileage Always check.
    Keep us posted on progress

    Verstuurd vanaf mijn E5823 met Tapatalk
    Last edited by AWH; 01-20-2020 at 08:04 PM.

  3. #3

    conozo's Avatar
    Join Date
    Jan 2005
    Vehicle
    1988 Honda Accord DX, 213,000 miles
    Location
    Fort Wayne, Indiana
    Posts
    793

    Re: Poor MPG and Engine Running Rich

    What kind of spark plugs did you use?

    Do you think you have fuel in the oil?

    1988 Honda Accord LSDX-I

  4. #4
    DX User
    Join Date
    Mar 2018
    Posts
    12

    Re: Poor MPG and Engine Running Rich

    The spark plugs are NGK I believe and maybe the wires. New from previous owner. I swapped out the Bosch 02 for a Denso and will see if this corrects the issue. No issues with the Cat its less than a year old. I didn't smell any fuel in the oil and no signs its going in there. Injectors were replaced last year as well. We'll see what this tank of gas does.

  5. #5
    3Geez Veteran
    Join Date
    Nov 2004
    Vehicle
    88 LXi
    Location
    Knoxville TN
    Posts
    4,065

    Re: Poor MPG and Engine Running Rich

    I will add a few things.

    The new Cat may effect mileage since its possible the old one was defective and or open.

    I am suspicious of the 50 mpg...personally I never seen more than 38? one time on one long trip with 94 Sunonco which they dont make any more. Some carb cars can do a little better. Realistically 30 mpg?

    I get 22-24 with E85 so you should be able to do better than that and my compression is about the same maybe lower.
    1988 Lxi owner since August 1995
    336k miles running strong!
    Now running E85.

    My Acura Type R front brake thread

    https://www.3geez.com/forum/showthrea...r+brake+option

  6. #6
    DX User
    Join Date
    Mar 2018
    Posts
    12

    Re: Poor MPG and Engine Running Rich

    The new cat is almost 2yrs old now so no issues there. This car always got excellent gas mpg but something is still off. Just got back from a 340mile road trip where I was cruising at 65 most of time with cruise control. Got 30mpg out of it. I drove this car cross country in 2018 with 1100lbs of stuff in it and was getting over 40 at 70mph plus.

  7. #7

    Dr_Snooz's Avatar
    Join Date
    Jun 2007
    Vehicle
    1989 Accord LX-i
    Location
    Fresno, California
    Posts
    9,841

    Re: Poor MPG and Engine Running Rich

    That mileage is about right for an LX-i. l do the same kind of driving every day and get just under 30. You were probably miscalculating before.
    Dr_Snooz

    "I like to take hammers, and just break stuff, just break stuff." - Beavis


    1989 Honda Accord LX-i Coupe, 220k miles, MT swap, rear disc swap

    Shop manual downloads available here: CLICK TO VIEW

Similar Threads

  1. running rich?
    By accordion89 in forum Classic Honda Community Chat
    Replies: 17
    Last Post: 03-13-2009, 01:35 PM
  2. Running Rich
    By barber107 in forum 3geez Accords
    Replies: 11
    Last Post: 11-25-2004, 12:19 PM
  3. Running Too Rich
    By Janiel in forum 3geez Accords
    Replies: 7
    Last Post: 06-14-2003, 09:57 PM
  4. Running Rich
    By 1987HondaAccord in forum EFI Tech
    Replies: 1
    Last Post: 01-10-2003, 01:35 PM
  5. Running rich in the wet?
    By 89AccordNate in forum 3geez Accords
    Replies: 7
    Last Post: 12-12-2002, 08:04 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge