Results 1 to 4 of 4

Thread: vss signal obd0 A20A3 engine

  1. #1
    DX User
    Join Date
    Jun 2020
    Vehicle
    honda prelude 1986
    Location
    chile
    Posts
    2

    Thumbs up vss signal obd0 A20A3 engine

    Hello everyone, this last time I have advanced in my project, which is giving me some problems related to engine power. therefore, I decided to consult the group in search of wisdom.

    It is an A20A3 engine, (BT says the block) I am not sure if it comes from an accord or a prelude, the car where I installed it is a 1983 prelude. The ecu that I got from a 1986 prelude has the code 37820 PJ0 663. ( This ecu, if I am not mistaken, is different from that of the accord a20a3 motor, because it does not have the outputs for the EGR connection, according to the prelude manual 1985-1986).

    I will explain the problem: when the car is stopped and I rev the engine, it does not exceed 6000 rpm, then when I go out on the street and accelerate it, it does not exceed 5000 revolutions and also backfires are heard.

    With the help of a strobe lamp, I regulated the advance in the distributor, leaving 15 degrees BTDC (mark that is on the flywheel) and according to the guide in the service manual.

    there is no code showing the ecu, there are no vacuum leaks.

    I have noticed two things that make me wonder.

    1. I don't have the vss signal connected, I don't know if it is related to the lack of power in these motors.

    In the service manual of an accors with a20a3 motor, it shows on pin out of the ecu that pin B18 has voltage values ​​between 0V - 3V.
    (I do not have the signal because the car cluster is not designed to connect to the ecu).

    2. When I checked the timing of the motor, notice that the camshaft sprocket has a little free play, it is not exaggerated, but I feel when releasing the bolt and moving a little movement from one side to the other, and the same happens with the crankshaft sprocket.

    With regard to the movement of the pinions, I made several measurements of keys with the intention of supplying the degrees that the pinions moved, but I still get the same result.

    Is it because of the vss signal? Or by the ECU?



  2. #2

    ShiRen's Avatar
    Join Date
    May 2018
    Vehicle
    87 Accord DX / 18 Civic Type R
    Location
    MO
    Posts
    208

    Re: vss signal obd0 A20A3 engine

    Retard the timing. I have no clue where 15deg came from, but the service manual calls for 4. Does your vacuum advance work? Here is the manual, start on page 765.
    Last edited by ShiRen; 07-14-2020 at 04:31 AM.

  3. #3


    Join Date
    Nov 2004
    Vehicle
    88 LXi
    Location
    Knoxville TN
    Posts
    4,231

    Re: vss signal obd0 A20A3 engine

    Quote Originally Posted by brunoprelude1983_6 View Post
    Hello everyone, this last time I have advanced in my project, which is giving me some problems related to engine power. therefore, I decided to consult the group in search of wisdom.

    It is an A20A3 engine, (BT says the block) I am not sure if it comes from an accord or a prelude, the car where I installed it is a 1983 prelude. The ecu that I got from a 1986 prelude has the code 37820 PJ0 663. ( This ecu, if I am not mistaken, is different from that of the accord a20a3 motor, because it does not have the outputs for the EGR connection, according to the prelude manual 1985-1986).

    I will explain the problem: when the car is stopped and I rev the engine, it does not exceed 6000 rpm, then when I go out on the street and accelerate it, it does not exceed 5000 revolutions and also backfires are heard.

    With the help of a strobe lamp, I regulated the advance in the distributor, leaving 15 degrees BTDC (mark that is on the flywheel) and according to the guide in the service manual.

    there is no code showing the ecu, there are no vacuum leaks.

    I have noticed two things that make me wonder.

    1. I don't have the vss signal connected, I don't know if it is related to the lack of power in these motors.

    In the service manual of an accors with a20a3 motor, it shows on pin out of the ecu that pin B18 has voltage values ​​between 0V - 3V.
    (I do not have the signal because the car cluster is not designed to connect to the ecu).

    2. When I checked the timing of the motor, notice that the camshaft sprocket has a little free play, it is not exaggerated, but I feel when releasing the bolt and moving a little movement from one side to the other, and the same happens with the crankshaft sprocket.

    With regard to the movement of the pinions, I made several measurements of keys with the intention of supplying the degrees that the pinions moved, but I still get the same result.

    Is it because of the vss signal? Or by the ECU?
    Check that the timing belt has not slipped one tooth or more. The belt should not be loose at all but very tight. The belt may be missing teeth.

    Rotate the crank by hand until the TDC top dead center mark is up and see where the cam sprocket is. The sprocket should have a "UP" marked on it.
    1988 Lxi owner since August 1995
    336k miles running strong!
    Now running E85.

    My Acura Type R front brake thread

    https://www.3geez.com/forum/showthrea...r+brake+option

  4. #4


    Join Date
    Nov 2004
    Vehicle
    88 LXi
    Location
    Knoxville TN
    Posts
    4,231

    Re: vss signal obd0 A20A3 engine

    https://www.youtube.com/watch?v=s86PfFQs9kM




    This might make more sense to you.
    1988 Lxi owner since August 1995
    336k miles running strong!
    Now running E85.

    My Acura Type R front brake thread

    https://www.3geez.com/forum/showthrea...r+brake+option

Similar Threads

  1. vss signal obd0 A20A3 engine
    By brunoprelude1983_6 in forum 3geez Accords
    Replies: 0
    Last Post: 07-13-2020, 06:58 PM
  2. Engine Swap (A20A3 to A20A3)
    By mike_fx_u in forum 3geez Accords
    Replies: 12
    Last Post: 06-02-2018, 07:15 PM
  3. My A20A3 Engine
    By McNaught87 in forum Classic Honda Pics & Videos
    Replies: 6
    Last Post: 04-07-2017, 11:52 AM
  4. check engine signal
    By snoopyloopy in forum 3geez Accords
    Replies: 2
    Last Post: 12-30-2005, 06:32 PM
  5. BT and A20A3 Engine
    By Supatech in forum Performance
    Replies: 2
    Last Post: 04-25-2004, 03:14 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
VigLink badge