Results 1 to 7 of 7

Thread: Stalling issue and had a code 12.

  1. #1

    Mike's89AccordLX's Avatar
    Join Date
    Aug 2002
    Vehicle
    1989/Honda/Accord LX/5-spd, 1994 Prelude Si/5-spd, 2004 Honda 1300 VTX
    Location
    Mankato, Minnesota
    Posts
    9,851

    Stalling issue and had a code 12.

    So, I had the code 12 and did a vacuum test on the EGR valve and it holds a vacuum and will stall out the car. So then from what I read it led me to the filters and cvc in the dreaded black box. I cleaned and gently blew out everything. The cvc valve took a little bit to have the cleaner go through it. And when gently blowing it out some black crud came out. I figured since I was cleaning things out I pulled the #3 hose off the black canister and was labeled pvc. When I added cleaner to that vacuum line and blew it out cleaner came out near the thermostat on a valve that has two vacuum lines on it. Is that telling me there's a vacuum leak there or is it supposed to vent there? It should be the last picture. Oh and it's an 87 LX-i. After I got done I started it and ran it for 20 minutes and no PGM-FI light so I took it for a drive. And maybe a half a mile into it the car stalled but never threw a PGM-FI light on. This happened 1 more time on the way back home. Any help would be appreciated.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20221030_160703.jpg 
Views:	7 
Size:	237.1 KB 
ID:	11147   Click image for larger version. 

Name:	20221030_161135.jpg 
Views:	8 
Size:	160.5 KB 
ID:	11148   Click image for larger version. 

Name:	20221030_162905.jpg 
Views:	6 
Size:	142.8 KB 
ID:	11149   Click image for larger version. 

Name:	20221030_164803.jpg 
Views:	7 
Size:	311.7 KB 
ID:	11150  
    Last edited by Mike's89AccordLX; 10-30-2022 at 02:41 PM.



  2. #2


    Join Date
    Nov 2004
    Vehicle
    88 LXi
    Location
    Knoxville TN
    Posts
    5,046

    Re: Stalling issue and had a code 12.

    only thing I can add is that last picture my thermostat housing does not have that thermo sensor with the two vacuum lines on it. Mine is a 87 lxi J code car.
    1988 Lxi owner since August 1995
    336k miles running strong!
    Now running E85.

    Oldblueaccord <<< MY YOUTUBE PAGE!

  3. #3

    Mike's89AccordLX's Avatar
    Join Date
    Aug 2002
    Vehicle
    1989/Honda/Accord LX/5-spd, 1994 Prelude Si/5-spd, 2004 Honda 1300 VTX
    Location
    Mankato, Minnesota
    Posts
    9,851

    Re: Stalling issue and had a code 12.

    Quote Originally Posted by Oldblueaccord View Post
    only thing I can add is that last picture my thermostat housing does not have that thermo sensor with the two vacuum lines on it. Mine is a 87 lxi J code car.
    That's what I saw on my spare motor it doesn't have the thermo sensor. But my spare motor is from an 89 lxi.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20221030_165323.jpg 
Views:	2 
Size:	253.6 KB 
ID:	11153  

  4. #4


    Join Date
    Nov 2004
    Vehicle
    88 LXi
    Location
    Knoxville TN
    Posts
    5,046

    Re: Stalling issue and had a code 12.

    Ok the back ground info I forgot to mention was the 1986 lxi have some unusual thermosensors like that for some reason. So you may consult the 86 book for some of that if there is one available.
    1988 Lxi owner since August 1995
    336k miles running strong!
    Now running E85.

    Oldblueaccord <<< MY YOUTUBE PAGE!

  5. #5

    Mike's89AccordLX's Avatar
    Join Date
    Aug 2002
    Vehicle
    1989/Honda/Accord LX/5-spd, 1994 Prelude Si/5-spd, 2004 Honda 1300 VTX
    Location
    Mankato, Minnesota
    Posts
    9,851

    Re: Stalling issue and had a code 12.

    Quote Originally Posted by Oldblueaccord View Post
    Ok the back ground info I forgot to mention was the 1986 lxi have some unusual thermosensors like that for some reason. So you may consult the 86 book for some of that if there is one available.
    It's funny you say that, because the build date is December of 1986. I did just order a 1987 Factory Service Manual and Electrical Manual on ebay for $43 shipped. Hard to beat that and I just like having the big books vs a pdf. So after checking the 86 Manual it looks like a Thermowax Switching Valve? The picture of the 87 Manual doesn't show it. But definitely there was some cleaner coming out of that valve when I was spraying MAF Sensor Cleaner in the vacuum line.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SmartSelect_20221101_014508_Chrome.jpg 
Views:	3 
Size:	466.9 KB 
ID:	11156   Click image for larger version. 

Name:	SmartSelect_20221101_014658_Chrome.jpg 
Views:	2 
Size:	455.8 KB 
ID:	11157   Click image for larger version. 

Name:	SmartSelect_20221101_020143_Chrome.jpg 
Views:	3 
Size:	217.4 KB 
ID:	11158  
    Last edited by Mike's89AccordLX; 10-31-2022 at 11:12 PM.

  6. #6


    Join Date
    Nov 2004
    Vehicle
    88 LXi
    Location
    Knoxville TN
    Posts
    5,046

    Re: Stalling issue and had a code 12.

    Quote Originally Posted by Mike's89AccordLX View Post
    It's funny you say that, because the build date is December of 1986. I did just order a 1987 Factory Service Manual and Electrical Manual on ebay for $43 shipped. Hard to beat that and I just like having the big books vs a pdf. So after checking the 86 Manual it looks like a Thermowax Switching Valve? The picture of the 87 Manual doesn't show it. But definitely there was some cleaner coming out of that valve when I was spraying MAF Sensor Cleaner in the vacuum line.

    Yes thermowax valve. It goes open at a certain temperature. There is a little was pellet I guess inside that moves with the temp. There are some post in the EFI section there was a guy that had an 86 with fuel injection he was troubleshooting something.

    PS. bleed the air out of your coolant of course it doesnt hurt.
    1988 Lxi owner since August 1995
    336k miles running strong!
    Now running E85.

    Oldblueaccord <<< MY YOUTUBE PAGE!

  7. #7

    Mike's89AccordLX's Avatar
    Join Date
    Aug 2002
    Vehicle
    1989/Honda/Accord LX/5-spd, 1994 Prelude Si/5-spd, 2004 Honda 1300 VTX
    Location
    Mankato, Minnesota
    Posts
    9,851

    Re: Stalling issue and had a code 12.

    I bought some coolant just to rule that out. I replaced the main relay with a brand new one. Car seemed to run fine and I get like a mile from home and it dies. It seems like a dead battery. However I know the battery and alternator was replaced this year. So I'm thinking the alternator might be junk causing the battery to fail.

    Update: I tested the battery, starter, alternator, and diode. All tested good. However I did find the negative battery cable is not in great shape where it connects to the engine.
    So it looks like I'll replace that cable and find all of the other engine grounds to start.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20221104_160708.jpg 
Views:	4 
Size:	402.6 KB 
ID:	11159  
    Last edited by Mike's89AccordLX; 11-04-2022 at 02:26 PM.

Similar Threads

  1. Stalling issue ('87 Accord LX)
    By Snowfox in forum 3geez Accords
    Replies: 9
    Last Post: 08-05-2012, 11:34 AM
  2. stalling issue
    By poison2003 in forum Carburetor Tech
    Replies: 38
    Last Post: 02-14-2011, 05:05 PM
  3. Replies: 19
    Last Post: 01-15-2007, 04:12 PM
  4. Stalling Out
    By dj99 in forum 3geez Accords
    Replies: 2
    Last Post: 12-05-2004, 11:47 AM
  5. stalling
    By Brentm in forum 3geez Accords
    Replies: 8
    Last Post: 06-11-2004, 07:32 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.
     
VigLink badge